• Benvenuto in Making Videogames!
  • Condividi la tua passione!
  • Crea il tuo Videogioco!
Benvenuto ospite! Login Registrati


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Title: Problema di una principiante!
Modi discussione
#1
Ciao a tutti,
sto iniziando a studiare le basi, seguendo il
unity3d.com/learn/tutorials/s/roll-ball-tutorial

Ma mi sono bloccata alla seconda lezione: non riesco a replicare il movimento della palla (si muove solo per gravità).
Ad es anche solo inserendo sullo script "Debug.Log("Ciao Mondo"), sulla console non appare nulla all'invio  (su un mac os):
Lo script è componente di una palla, e al play l'interfaccia diventa "blu",
ma sulla console non scrive nulla.   Blush

Ecco il codice di prova:

using System.Collections;
using System.Collections.Generic;
using UnityEngine;

public class PlayerController : MonoBehaviour {

private Rigidbody rb;
// Use this for initialization
void Start () {
Debug.Log("Ciao Mondo!");
//rb = GetComponent<rigidbody> ();
}

// Update is called once per frame
void FixedUpdate () {
float x = Input.GetAxis ("Horizontal");
float z = Input.GetAxis ("Vertical");
//rb.AddForce (new Vector3(x,0.0f,z));
Debug.Log(Input.GetAxis("Horizontal"));
Debug.Log("ciaooo");

Debug.Log(string.Format("x y", x,z));
//transform.Translate (0.3f,0,0);

}
}

Grazie!  Smile
 
#2
Ciao Big Grin
Beh allora, sicuramente non è un errore di codice.
Sei sicura di aver attaccato lo script come components? Lo script è attivo o e disabilitato?
 
#3
Si bisogna verificare a cosa è attaccato lo script e se l'oggetto è attivo o meno sulla scena.
 
#4
Ciao!!! Ho trovato, grazie mille! Smile
Mi vergogno ma..sbagliavo tab della console, controllavo l'output su quello sbagliato
Inoltre semplicemente mi muovevo a sufficienza coi tasti Tongue
Scusate!
 
#5
Ah tranquillo all'inizio può succedere ;p
 
#6
(13-01-2018, 11:56 AM)Annina Ha scritto: Ciao!!! Ho trovato, grazie mille! Smile
Mi vergogno ma..sbagliavo tab della console, controllavo l'output su quello sbagliato
Inoltre semplicemente mi muovevo a sufficienza coi tasti Tongue
Scusate!

Come ha detto il nostro caro bb3b, all'inizio succede a tutti Smile
Hai fatto bene in ogni caso a segnalarci il problema ahah Big Grin
 
  


Discussioni simili
Discussione Autore Risposte Letto Ultimo messaggio
  Problema con le texture di alcuni modelli Gustibro 8 1,087 05-10-2013, 03:00 PM
Ultimo messaggio: BlaClex46
  Problema di apertura con unity 3d GibboSKQ 7 1,448 01-04-2013, 04:05 AM
Ultimo messaggio: echo_92

Vai al forum:


Browsing: 1 Ospite(i)